设为首页加入收藏

微信关注
官方微信号:71712643
加关注获取每日精选资讯
南方财富网欢迎您加入
广告服务联系我们网站地图

徐小明选股源代码 徐小明的123求4公式

2014-10-13 09:57 南方财富网 www.southmoney.com

  徐小明选股源代码 徐小明的123求4公式

  A1:=REF(HIGH,3)=HHV(HIGH,2*3+1); B1:=FILTER(A1,3); C1:=BACKSET(B1,3+1); D1:=FILTER(C1,3);{高点}

  A2:=REF(LOW,3)=LLV(LOW,2*3+1); B2:=FILTER(A2,3); C2:=BACKSET(B2,3+1); D2:=FILTER(C2,3);{低点}

  E1:=(REF(LLV(LOW,2*3),1)+REF(HHV(HIGH,2*3),1))/2; E2:=(HIGH+LOW)/2;{高低点出现在同一K线上时可作取舍}

  H1:=(D1 AND NOT(D2 AND E1》=E2)) OR barstatus=2 OR BARSCOUNT(CLOSE)=1;

  L1:=(D2 AND NOT(D1 AND E1《E2)); H2:=D1 AND NOT(D2 AND E1》=E2);

  X1:=REF(BARSLAST(H1),1)+1; F1:=BACKSET(H1 AND COUNT(L1,X1)》0,LLVBARS(IF(L1,LOW,10000),X1));

  G1:=F1》REF(F1,1); I1:=BACKSET(G1,2); LD:=I1》REF(I1,1);{过滤后低点}

  L2:=LD OR barstatus=2 OR BARSCOUNT(CLOSE)=1;

  X2:=REF(BARSLAST(L2),1)+1; F2:=BACKSET(L2 AND COUNT(H2,X2)》0,HHVBARS(IF(H2,HIGH,0),X2));

  G2:=F2》REF(F2,1); I2:=BACKSET(G2,2); HD:=I2》REF(I2,1);{过滤后高点}

  DRAWLINE(LD,L,HD,H,0),COLORWHITE{,LINETHICK3},POINTDOT;

  DRAWLINE(HD,H,LD,L,0),COLORWHITE{,PLINETHICK3},POINTDOT;

  J1:=BACKSET(barstatus=2 ,MIN(BARSLAST(HD),BARSLAST(LD))+1); J2:=J1》REF(J1,1);

  DRAWLINE(J2,IF(HD,H,L),barstatus=2 ,IF(BARSLAST(HD)》BARSLAST(LD),H,L),0),COLORWHITE,POINTDOT;

  {以下是两条趋势线原码}

  UU:=BACKSET(barstatus=2 ,BARSLAST(LD)+1);

  VV:=UU》REF(UU,1);

  WW:=BACKSET(VV,REF(BARSLAST(LD),1)+2);

  XX:=WW》REF(WW,1);

  DRAWLINE(XX,L,VV,L,1),COLORMAGENTA{,LINETHICK2};

  UU2:=BACKSET(barstatus=2 ,BARSLAST(HD)+1);

  VV2:=UU2》REF(UU2,1);

  WW2:=BACKSET(VV2,REF(BARSLAST(HD),1)+2);

  XX2:=WW2》REF(WW2,1);

  前一低:=REF(L,BARSLAST(VV)){,COLOR99FF66,POINTDOT,LINETHICK1};

  前二低:=REF(L,BARSLAST(XX)){,COLORFF66FF,POINTDOT,LINETHICK1};

  前一高:=REF(H,BARSLAST(VV2)){,COLOR99FF66,POINTDOT,LINETHICK1};

  前二高:=REF(H,BARSLAST(XX2)){,COLORFF66FF,POINTDOT,LINETHICK1};

  求4看空:h*前一低/if(前一高=h,前二高,前一高);

  求4看多:l*前一高/if(前一低=l,前二低,前一低);

(南方财富网SOUTHMONEY.COM)

南方财富网声明:资讯来源于合作媒体及机构,属作者个人观点,仅供投资者参考,并不构成投资建议。投资者据此操作,风险自担。